Topic: WebDAV access from Zotero fails

Hi,

I am using Zotero (v4.0.19) with CloudMe WebDAV to synchronize attachments. In the recent weeks Zotero started throwing errors on sync attempts, something along the following lines:

[JavaScript Error: "HTTP 502 error from WebDAV server for OPTIONS request" {file: "chrome://zotero/content/xpcom/storage/webdav.js" line: 1131}]

[JavaScript Error: "xmlhttp.responseXML is null" {file: "chrome://zotero/content/xpcom/storage/webdav.js" line: 1645}]

Having checked the Zotero options, I see that my WebDAV url is [url]https://webdav.cloudme.com/autarkie/xios/Documents/zotero.[/url] Pressing "Verify Server" gives "https://webdav.cloudme.com/autarkie/xios/Documents/zotero is not a valid WebDAV URL". Now, I have been using this URL for a year or so, and it was definitely correct before. Also, just *sometimes*, Zotero does manage to synchronize the attachments. The problem is thus intermittent, and I have it on all my machines.

Any ideas as to why this may occur?

Thanks!

Last edited by autarkie (2014-04-09 08:44:38)

Re: WebDAV access from Zotero fails

I'm having the same problem. Prior to this the WebDAV url worked fine, now Zotero says it's not valid. The sync works sometimes, for example yesterday I did it few times, but now it just keeps throwing error.

Re: WebDAV access from Zotero fails

According to [url]https://www.zotero.org/support/4.0_changelog[/url]

Changes in 4.0.19 (March 21, 2014)
Fixed WebDAV syncing (since 4.0.18) <<<<<<<<<<<<<<<<<
Fixed Date Modified of some attachment items being updated unnecessarily during syncing (since 4.0.18)
Added Lithuanian locale
Allow Unicode characters in Zotero username in Sync preferences