Topic: trouble running cloudme-sync on linux x64 debian

Hi,
I installed cloudme-sync_1.8.0-1.1_amd64.deb and I installed manually the missing libraries (qt5...).
But it's still not working.

$ ldd /usr/bin/cloudme-sync 
    linux-vdso.so.1 (0x00007fff079e2000)
    libcrypto.so.1.0.0 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007f4a43a8f000)
    libgnome-keyring.so.0 => /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 (0x00007f4a4386a000)
    libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f4a4356a000)
    libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f4a42d60000)
    libQt5Sql.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5 (0x00007f4a42b22000)
    libQt5Xml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5 (0x00007f4a428e6000)
    libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007f4a4259f000)
    libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f4a41f7f000)
    libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f4a41917000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f4a416fb000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f4a413f8000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4a410f9000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f4a40ee3000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f4a40b37000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f4a40932000)
    libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f4a406e2000)
    libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f4a404de000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f4a402d5000)
    libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f4a4008f000)
    libgcrypt.so.11 => /lib/x86_64-linux-gnu/libgcrypt.so.11 (0x00007f4a3fe10000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f4a3fbd1000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f4a3f896000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f4a3f67d000)
    libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f4a3f456000)
    libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f4a3f128000)
    libicui18n.so.48 => /usr/lib/x86_64-linux-gnu/libicui18n.so.48 (0x00007f4a3ed60000)
    libicuuc.so.48 => /usr/lib/x86_64-linux-gnu/libicuuc.so.48 (0x00007f4a3e9f3000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f4a43ea4000)
    libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f4a3e7eb000)
    libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f4a3e5e5000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f4a3e3c7000)
    libnvidia-tls.so.319.72 => /usr/lib/x86_64-linux-gnu/tls/libnvidia-tls.so.319.72 (0x00007f4a3e1c4000)
    libnvidia-glcore.so.319.72 => /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.319.72 (0x00007f4a3bc68000)
    libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f4a3ba56000)
    libicudata.so.48 => /usr/lib/x86_64-linux-gnu/libicudata.so.48 (0x00007f4a3a6e6000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f4a3a4e1000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f4a3a2dc000)

When I run cloudme-sync, the GUI opens, I enter my username & password, but nothing happens.
There's an error message saying:
DB ERROR: "Driver not loaded Driver not loaded" 

Here is the output from the shell:

$ cloudme-sync 
CloudMeUnthreaded:resetNetworkAccessManager()  
Unknown property z-index 
Unknown property z-index 
Unknown property z-index 
Unknown property z-index 
Unknown property z-index 
Unknown property z-index 
Unknown property z-index 
Unknown property z-index 
MainWindow geometry: ( "630" , "458" )  
SyncManager lives in:  0x7fe16dc61740  
CloudMeRequest:  "POPMESSAGE"  : Host-> "[url]https://83.140.241.8/v1/[/url]"  
Setting up syncThread  
setupSyncThread() Thread:  0x7fe16dc61740  
State:  0  
onSetup() Thread:  0x7fe1421bc700  
UploadManager::resetNetworkAccessManager()  
UploadManager::resetNetworkAccessManager()  
CloudMeUnthreaded:resetNetworkAccessManager()  
CloudMeRequest:  "POPMESSAGE"  : Host-> "[url]https://83.140.241.10/v1/[/url]"  
initiateSettings  
Init Alive Poll  
justUpdated  
checkForUpdates  
checkForNewVersion  
in checkForNewVersion  
after checkForNewVersion  
in checkUserAutomaticLogin  
CloudMeRequest:  "login"  : Host-> "[url]https://83.140.241.7/v1/[/url]"  
CloudMeUnthreaded::finished-> "2"  Time:  "2014-04-13 18:03:35 185"  
CloudMeUnthreaded::finished-> "2"  Time:  "2014-04-13 18:03:35 215"  
CloudMeUnthreaded::finished-> "1"  Time:  "2014-04-13 18:03:36 147"  
onLoginSuccess  
sqManager datalocation:  "/home/dem/.local/share/CloudMe/Sync/cache.db"  
DB ERROR: "Driver not loaded Driver not loaded"  
CloudMeRequest:  "POPMESSAGE"  : Host-> "[url]https://83.140.241.9/v1/[/url]"  
onTrayShow  
CloudMeUnthreaded::finished-> "2"  Time:  "2014-04-13 18:03:36 301"  
password saved successfully!  
CloudMeRequest:  "login"  : Host-> "[url]https://83.140.241.8/v1/[/url]"  
CloudMeUnthreaded::finished-> "1"  Time:  "2014-04-13 18:03:43 797"  
onLoginSuccess  
DB ERROR: "Driver not loaded Driver not loaded"  
CloudMeRequest:  "POPMESSAGE"  : Host-> "[url]https://83.140.241.10/v1/[/url]"  
onTrayShow  
CloudMeUnthreaded::finished-> "2"  Time:  "2014-04-13 18:03:43 981"  
^C

Here's the log file (french localisation), the error is
QSqlDatabase: QSQLITE driver not loaded

$ cat /home/myuser/.local/share/CloudMe/Sync/logs/2014-04-13.txt
2014-04-13 16:03:34: QString::arg: Argument missing: Connect� en tant que% 1. Cliquez ici pour ouvrir CloudMe Web Access et �tre en mesure de g�rer vos fichiers en ligne., 
2014-04-13 16:03:34: QString::arg: Argument missing: Connect� en tant que% 1. Cliquez ici pour ouvrir CloudMe Web Access et �tre en mesure de g�rer vos fichiers en ligne., 
2014-04-13 16:03:34: LOGIN->SSLSUPP: true  host:  "[url]https://os.cloudme.com/v1/[/url]" 
2014-04-13 16:03:36: QString::arg: Argument missing: Connect� en tant que% 1. Cliquez ici pour ouvrir CloudMe Web Access et �tre en mesure de g�rer vos fichiers en ligne., demiurge
2014-04-13 16:03:36: Logged in as: "demiurge" 
2014-04-13 16:03:36: QSqlDatabase: QSQLITE driver not loaded
2014-04-13 16:03:36: QSqlDatabase: available drivers: 
2014-04-13 16:03:43: LOGIN->SSLSUPP: true  host:  "[url]https://os.cloudme.com/v1/[/url]" 
2014-04-13 16:03:43: QString::arg: Argument missing: Connect� en tant que% 1. Cliquez ici pour ouvrir CloudMe Web Access et �tre en mesure de g�rer vos fichiers en ligne., demiurge
2014-04-13 16:03:43: Logged in as: "demiurge" 
2014-04-13 16:03:43: QSqlDatabase: QSQLITE driver not loaded
2014-04-13 16:03:43: QSqlDatabase: available drivers: 
2014-04-13 16:03:43: QSqlDatabasePrivate::removeDatabase: connection 'qt_sql_default_connection' is still in use, all queries will cease to work.
2014-04-13 16:03:43: QSqlDatabasePrivate::addDatabase: duplicate connection name 'qt_sql_default_connection', old connection removed.
$ lsb_release -a
No LSB modules are available.
Distributor ID:    LinuxMint
Description:    Linux Mint Debian Edition
Release:    1
Codename:    debian

$ uname -a 
Linux xxxx 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) x86_64 GNU/Linux

Last edited by demiurge (2014-04-13 16:15:00)

Re: trouble running cloudme-sync on linux x64 debian

I've just had the same experience. I've installed 1.8.8, and had the same problem, with pretty much the same log messages (except that mine is in English...).